Задать вопрос
7 сентября, 22:03

Помогите решить 2 задачи!

1. Составить программу перевода километров в метры.

2. Для туристической поездки в Турцию на 7 дней понадобится: Х тенге в сутки на гостиницу, У тенге в сутки на питание. Также предполагается потратить В тенге на сувениры. Определите сумму необходимую для поездки.

+5
Ответы (1)
  1. 8 сентября, 00:29
    0
    Var

    a, b:integer;

    begin

    writeln ('введите число (км) ') ;

    readln (a) ;

    b:=a*1000

    writeln ('метры = ', b) ;

    end.

    задание 2

    program dfg;

    var

    x, y, b, d:real;

    begin

    writeln ('введите стоимость гостиницы (за сутки) ') ;

    readln (x) ;

    if x>0 then

    begin

    writeln ('введите стоимость питания (за сутки) ') ;

    readln (y) ;

    if y>0 then

    beginwriteln ('введит стоимость сувинир (за сутки) ') ;

    readln (b) ;

    if b>0 then

    begin

    d: = (x+y+b) * 7;

    writeln ('необходимая сумма', d) ;

    end

    else

    writeln ('число не может быть отрицательным') ;

    end

    else

    writeln ('число не может быть отрицательным') ;

    end

    else

    writeln ('число не может быть отрицательным') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить 2 задачи! 1. Составить программу перевода километров в метры. 2. Для туристической поездки в Турцию на 7 дней понадобится: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все учащиеся класса за три года посетили либо Турцию, либо Египет, либо побывали в обеих странах. Известно, что в Египет летали 18 человек, в Турцию-21, а обе страны посетили 7 человек. Сколько всего учащихся в классе?
Ответы (1)
Задачи циклические Паскаль: Составить алгоритмы и программы перевода старинных русских мер длины, торгового и аптекарского веса (счетчик цикла меняется от 1 до 10) : саженей в метры (1 сажень равна 2,1366 м) футов в метры (1 фут равен 0,3048 м)
Ответы (1)
Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней
Ответы (2)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Температура в градусац Цельсия изменяется от 0 до 100 с шагом 5. Написать программу перевода температуры из градусов Цельсия в градусы Фаренгейта (F). Формула перевода: F=1.8+32.
Ответы (2)