Задать вопрос
20 февраля, 07:36

Температура в градусац Цельсия изменяется от 0 до 100 с шагом 5. Написать программу перевода температуры из градусов Цельсия в градусы Фаренгейта (F). Формула перевода: F=1.8+32.

+4
Ответы (2)
  1. 20 февраля, 08:10
    0
    Program C2F;

    Uses

    Crt;

    Var i: integer;

    c, f: real;

    Begin

    ClrScr; {очистить экран}

    Writeln ('From Celsius to Fahrenheit:') ;

    Write ('Type temperature (in celsius) : ') ; read (c) ;

    f : = 32 + 2*c * (1 - 1/10) ;

    Writeln ('Temperature in fahrenheit: ', f:3:3) ;

    { : 3:3 - общее количество знаков и знаков после запятой }

    Writeln (' Celsius to Fahrenheit from 0 to 100, step 5: ') ;

    i : = 0;

    While i < = 100 Do

    Begin

    f : = 32 + 2*i * (1 - 1/10) ;

    Writeln (' C = ', i:3,' | F = ', f:3:3) ;

    i : = i + 5;

    End;

    Readkey; {чтоб не нажимать alt+f5 для просмотра результатов}

    End.
  2. 20 февраля, 11:06
    0
    программа на паскале

    var a: array [1 ... 21,1 ... 2] of real;

    i:integer;

    begin

    a[1,1]:=0.0;

    for i:=2 to 21 do

    a[i, 1]:=a[i-1,1]+5;

    for i:=1 to 21 do

    a[i, 2]:=a[i, 1]*1.8+32.0;

    for i:=1 to 21 do

    writeln (a[i, 1]:3:0,' celcia = ', a[i, 2]:3:0,' farrengeit') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Температура в градусац Цельсия изменяется от 0 до 100 с шагом 5. Написать программу перевода температуры из градусов Цельсия в градусы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа в pascal, переводящая градусы цельсися в градусы фаренгейта и градусы кельвина. f=1.8c+32, где f-градусы фаренгейта, с-градусы цельсия. k=c+273, где k-градусы кельвина, с-градусы цельсия
Ответы (1)
Температура в градуса Цельсия изменяется от 0 до 100 с шагом 5. Написать программу перевода температуры из градусов Цельсия в градусы Фаренгейта (F). Формула перевода: F=1.8+32.
Ответы (1)
Напечатать перевод температуры из градусов по шкале Цельсия (С) в градусы по шкале Фаренгейта (F) для значений температуры от 0 0 С до 400 С с шагом 5 0 С. Формула перевода F=1,8 С+32. Паскаль. Циклы с условием
Ответы (1)
Составе программу для преобразования F градусов температуры, заданной по шкале Фаренгейта в градусы С по шкале Цельсия по приведенной ниже формуле. исходное значение температуры F задается с клавиатуры. С=5/9 (F-32)
Ответы (1)
Определить температуру и вес вашего тела соответственно в фунтах и по шкале фаренгейта, (1 фунт = 400 г). Перевод из градусов по шкале Цельсия в градусы по шкале Фаренгейта осуществляется по формуле: Tp=1.8*ta+32 Линейная программа
Ответы (1)