Задать вопрос
4 мая, 20:21

Как в двумерном массиве найти среднее арифметическое однозначных элементов

+1
Ответы (1)
  1. 4 мая, 22:28
    0
    ПаскальАВС. НЕТ

    const

    n=5;

    m=6;

    var

    i, j, s, k:integer;

    a:array[1 ... n, 1 ... m]of integer;

    begin

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (-50,50) ;

    write (a[i, j]:5) ;

    if abs (a[i, j]) <10 then

    begin

    s:=s+a[i, j];

    k:=k+1;

    end;

    end;

    writeln;

    end;

    writeln ('Ответ: ', s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как в двумерном массиве найти среднее арифметическое однозначных элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Информатика. Массивы. PascalABC. 1. В двумерном массиве 4 х5 вычислить сумму элементов кратных 3, значения которых больше 20. 2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5 х5.
Ответы (1)
В двумерном массиве размерностью N*M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк
Ответы (1)
В двумерном массиве найти количество четных чисел и среднее арифметическое всех элементов масива
Ответы (1)