Задать вопрос
20 августа, 05:18

Помогите написать программу в паскали. Дан одномерный массив A[N]. Найти произведение четных чисел и сумму нечетных.

+2
Ответы (1)
  1. 20 августа, 07:18
    0
    Const

    n = 5;

    var

    a: array [1 ... n] of byte;

    s, k: longint;

    b: byte;

    begin

    k : = 1;

    for b : = 1 to n do

    begin

    a[b] : = random (1, 11) ;

    write (a[b]:3) ;

    end;

    writeln () ;

    for b : = 1 to n do

    if (a[b] mod 2 = 1) then

    s : = s + a[b]

    else

    k : = k * a[b];

    for b : = 1 to n do

    writeln (s, ' ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскали. Дан одномерный массив A[N]. Найти произведение четных чисел и сумму нечетных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)