Задать вопрос
26 февраля, 14:58

Ребят помогите с задачей в Pacal.

Натуральное число называется палиндромом, если его запись читается одинаково с начала и с конца (например: 1,22,393). Найти все меньшие 100 натуральные числа, которые при возведении в квадрат дают палиндром.

+3
Ответы (1)
  1. 26 февраля, 15:33
    0
    Var

    i, w, q, e:integer;

    begin

    for i:=1 to 100 do

    begin

    q:=0;

    w:=i*i;

    e:=w;

    while e>0 do

    begin

    q:=q*10 + e mod 10;

    e:=e div 10;

    end;

    if q=w then

    write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят помогите с задачей в Pacal. Натуральное число называется палиндромом, если его запись читается одинаково с начала и с конца ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)
Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)
Дано двузначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)
Задача F Четный палиндром Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа. У Азизхана есть строка S.
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)