Задать вопрос
3 ноября, 23:30

Пусть

y0 = 0; yk = (yk-1 + 1) / (yk-1 + 2), k = 1, 2, ...

Дано действительное число ε > 0. Найти первый член yn, для которого вы-

полнено yn - yn-1 < ε.

Pascal, помогите решить.

+2
Ответы (1)
  1. 3 ноября, 23:52
    0
    Var

    y0, yk, yk1, eps, d: double;

    i: integer;

    begin

    y0 : = 0; yk1 : = y0;

    Write ('Введите величину погрешности: ') ;

    Readln (eps) ;

    repeat

    yk : = (yk1 + 1) / (yk1 + 2) ;

    d : = yk - yk1;

    if d > = eps then yk1 : = yk

    until d < eps;

    Writeln ('yn=', yk)

    end.

    Тестовое решение:

    Введите величину погрешности: 1e-8

    yn=0.618033988205325
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пусть y0 = 0; yk = (yk-1 + 1) / (yk-1 + 2), k = 1, 2, ... Дано действительное число ε > 0. Найти первый член yn, для которого вы- полнено ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. дано действительное число x и целое число n вывести N первых челнов арифметическойкой прогрессии и найти сумму ее первых членов если первый член X а разность 1,12 2.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)