Задать вопрос
31 января, 02:52

Дан массив из n элементов. в нем четные числа заменить на 0, а нечетные на - 1, вывести на экран монитора содержимое массива до обработки и после обработки

+4
Ответы (1)
  1. 31 января, 04:49
    0
    Const n = 5; / / задаем количество элементов массива (например 5)

    var

    a: array [1 ... n] of integer;

    i : integer;

    begin

    for i: = 1 to n do

    writeln (a[i]) ; / / вывод исходного массива

    for i: = 1 to n do

    begin

    if a[i] mod 2 = 0 then a[i] : = 0 else a[i] : = - 1; / / замена четных и нечетных элементов writeln (a[i]) ; / / вывод нового массива

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов. в нем четные числа заменить на 0, а нечетные на - 1, вывести на экран монитора содержимое массива до обработки и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан массив из N элементов. определить сумму тех, которые четны и положительны. 2) Дан массив из n элементов. В нем четные числа заменить на 0, нечетные на - 1, вывести на экран монитора содержимое массива до обработки и после обработки.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)