Задать вопрос
26 октября, 13:51

C4.

На плоскости дан набор точек с целочисленными координатами. Найти площадь наибольшего четырёхугольника, у которого 2 точки лежат на оси ОХ, а 2 другие по разные стороны от оси ОХ.

+1
Ответы (1)
  1. 26 октября, 16:57
    0
    Type

    mas=array[,]of integer;

    var

    i, n:integer;

    a:mas;

    b:array[1 ... 4]of integer;

    begin

    write ('Сколько точек: ') ;

    readln (n) ;

    setlength (a, 3, n+1) ;

    for i:=1 to n do

    begin

    write ('Введите координаты точки: ') ;

    readln (a[1, i], a[2, i]) ;

    end;

    for i:=1 to n do

    begin

    if a[2, i]=0 then

    begin

    if b[1]=0 then b[1]:=i else if a[1, i]
    if b[2]=0 then b[2]:=i else if a[1, i]>a[1, b[2]] then b[2]:=i;

    end;

    if a[2, i]>0 then

    if b[3]=0 then b[3]:=i else if a[2, i]>a[2, b[3]] then b[3]:=i;

    if a[2, i]<0 then

    if b[4]=0 then b[4]:=i else if a[2, i]
    end;

    writeln ('Координаты вершин четырехугольника с наибольшей площадью:') ;

    for i:=1 to 4 do write (' (', a[1, b[i]],'; ', a[2, b[i]],') ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «C4. На плоскости дан набор точек с целочисленными координатами. Найти площадь наибольшего четырёхугольника, у которого 2 точки лежат на оси ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Вычислить количество точек с целочисленными координатами, находящихся в круге радиуса R (R>0) с центром в начале координат. (Паскаль. Цикл. Без массива)
Ответы (1)
Два игрока играют в следующую игру. На координатной плоскости стоит фишка. Игроки ходят по очереди. В начале фишка находится в точке с координатами (-2; 1).
Ответы (1)
Паскаль! На плоскости заданы три точки своими координатами. Определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
Ответы (1)
4. Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b - целые числа), перемещающую Чертёжника из точки с координатами (x, y) в точку с
Ответы (1)