Задать вопрос
1 ноября, 17:37

Вычислить количество точек с целочисленными координатами, находящихся в круге радиуса R (R>0) с центром в начале координат. (Паскаль. Цикл. Без массива)

+2
Ответы (1)
  1. 1 ноября, 18:52
    0
    Var

    r, r2, x, y: real;

    n: integer;

    begin

    Write ('Введите величину радиуса окружности: ') ; Readln (r) ;

    r2 : = sqr (r) ; n : = 0;

    {1. Точки в первой четверти без учета попавших на оси }

    x : = 1;

    while x < = r do

    begin

    y : = 1;

    while y < = r do

    begin

    if sqr (x) + sqr (y) < = r2 then n : = n + 1;

    y : = y + 1

    end;

    x : = x + 1

    end;

    n : = 4 * n; { учли точки в остальных трех четвертях }

    n : = n + 1; { учли точку в начале координат }

    n : = n + 4 * trunc (r) ; { учли точки, находящиеся на координатных осях }

    Writeln ('Число точек, принадлежащих кругу, равно ', n) ;

    end.

    Тестовое решение:

    Введите величину радиуса окружности: 3

    Число точек, принадлежащих кругу, равно 29
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить количество точек с целочисленными координатами, находящихся в круге радиуса R (R>0) с центром в начале координат. (Паскаль. Цикл. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Запишите логическое выражение, истинное при выполнении указанного условия и ложное в противном случае: Точка с координатами (х, у) лежит в круге радиуса r с центром в начале координат
Ответы (1)