Задать вопрос
26 февраля, 03:37

Составить программу в паскале для определения является ли заданное слово палиндромом

+3
Ответы (1)
  1. 26 февраля, 04:01
    0
    Var

    x:string;

    i, w:integer;

    begin

    w:=0;

    readln (x) ;

    for i:=1 to length (x) div 2 do

    if x[i]x[length (x) - i+1] then

    w:=w+1;

    if w=0 then writeln ('Палиндром') else

    writeln ('Не палиндром') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале для определения является ли заданное слово палиндромом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Составить программу в qbasic проверяющую является ли заданное число палиндромом
Ответы (1)
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)