Задать вопрос
27 апреля, 20:43

Дан одномерный массив. Упорядочить массив удалив нули со сдвигом влево ненулевых элементов.

+4
Ответы (1)
  1. 27 апреля, 22:19
    0
    Const n=10;

    var a:array [1 ... n] of integer;

    i, j, k, l:integer;

    begin

    {создание и вывод массива}

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    {сортировка массива}

    for j:=1 to n do

    for i:=1 to n-1 do

    if a[i]>a[i+1] then

    begin

    k:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=k;

    end;

    {Удаление нулей}

    k:=0;

    while kn do

    begin

    k:=k+1;

    if a[k]=0 then

    begin

    l:=l+1;

    for i:=k to n-1 do

    a[i]:=a[i+1];

    end;

    end;

    {Вывод массива}

    for i:=1 to n-l do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив. Упорядочить массив удалив нули со сдвигом влево ненулевых элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)