Задать вопрос
10 декабря, 10:17

Написать программу которая введенные с клавиатуры отрицательные числа удваивает и прибавляет 5 а положительные оставляет без изменения

+5
Ответы (1)
  1. 10 декабря, 13:41
    0
    Program zz;

    var a:integer;

    begin

    readln (a) ;

    if a>0 then writeln (a)

    else

    begin

    a:=a*2+5;

    writeln (a) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая введенные с клавиатуры отрицательные числа удваивает и прибавляет 5 а положительные оставляет без изменения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.
Ответы (1)
Помогите составить задачу! Составить блок-схему которая из 3-х введенных с клавиатуры чисел в квадрат возводит только положительные, а отрицательные оставляет без изменения.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Имеется исполнитель "Двоечка", имеющий следующую последовательность команд: 1. Удваивает данное число. 2. Прибавляет к данному числу 2, если данное число четное и вычитает из данного числа 2, если данное число нечетное. 3.
Ответы (1)