Задать вопрос
11 ноября, 16:34

Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.

+2
Ответы (1)
  1. 11 ноября, 18:05
    0
    Var

    s: string;

    i, n: integer;

    a: set of char;

    begin

    Writeln ('Введите строку текста') ;

    Readln (s) ;

    n : = 0;

    a : = ['А', 'а'];

    for i : = 1 to Length (s) do

    if (s[i] = ' ') and (s[i - 1] in a) then n : = n + 1;

    if (s[i - 1] in a) then n : = n + 1;

    Writeln ('Количество слов, оканчивающихся буквой "а", равно ', n)

    end.

    Тестовое решение:

    Введите строку текста

    А роза упала на лапу Азора

    Количество слов, оканчивающихся буквой "а", равно 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Напишите программу, которая подсчитывает сумму всех цифр в данной строке. Например, в строке "Sochi-2014" сумма цифр равна 7. Формат входных данных Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.
Ответы (1)
Паскаль 1) Задана строка, проверить есть ли в этой строке буква "а" 2) задана строка, проверить сколько раз встречаться в этой строке буква "м" 3) задана строка, удалить из этой строки все буквы "и"
Ответы (1)
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)
1. Написать программу, которая подсчитывает периметр квадрата, площадь которого равна а. 2. Написать программу, которая подсчитывает площадь равностороннего треугольника, периметр которого равен p
Ответы (1)