Задать вопрос
11 июля, 02:02

Составить программу определяющую является ли число простым

+3
Ответы (1)
  1. 11 июля, 05:25
    0
    Самое простое из того, что смог придумать. Перебираем числа до половины необходимого (больше нет смысла) (for i : = 2 to number div 2 do) и ищем есть ли делители (number mod i = 0). Выводим сообщение.

    var

    number, i : integer;

    begin

    write ('Число: ') ;

    readln (number) ;

    for i : = 2 to number div 2 do

    if number mod i = 0 then

    begin

    writeln ('Число не является простым, оно делится, как минимум, на ', i) ;

    Exit;

    end;

    writeln ('Число является простым') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу определяющую является ли число простым ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)
Задание 1. составьте программу, определяющую, является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей, кроме 1 и его самого.
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)