Задать вопрос
10 марта, 16:21

Составте программу в паскале.

В целочисленном массиве из 10 чисел найти максимум и минимум и вывести на печать те элементы, которые находятся между максимумом и минимумом.

+1
Ответы (1)
  1. 10 марта, 19:47
    0
    Procedure massiv;

    var a:array[1 ... 10] of integer;

    i, max, min:integer;

    begin

    min:=1;

    max:=1;

    randomize;

    for i:=1 to 10 do

    begin

    a[i]:=random (100) ;

    if a[i]
    if a[i]>a[max] then max:=i;

    write (a[i],' ') ;

    end;

    writeln ('Минимальное ', a[min], ' Максимальное ', a[max]) ;

    if min
    for i: = min+1 to max-1 do

    write (a[i],' ') else

    for i: = max+1 to min-1 do

    write (a[i],' ')

    end;

    begin

    massiv ()

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу в паскале. В целочисленном массиве из 10 чисел найти максимум и минимум и вывести на печать те элементы, которые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "NO". В паскале.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)