Задать вопрос
24 мая, 08:07

Вывести щестизначных "счастливых" чисел (сумма первых трех цифр равна сумме трех последних), кратных семи в 10 колонок.

+1
Ответы (2)
  1. 24 мая, 10:01
    0
    Uses crt;

    var

    chislo, i, happy, ten: integer;

    a: array [1 ... 6] of integer;

    begin

    happy : = 100002; {наименьшее число, кратное 7}

    ten:=1; {счётчик колонок}

    while happy<999999 do

    begin

    {делим число happy на цифры с помощью временной переменной chislo}

    {и сохраняем эти цифры в массиве а}

    chislo : = happy;

    for i: = 1 to 6 do

    begin

    a[i] : = chislo mod 10;

    chislo: = chislo div 10;

    end;

    {проверяем, счастливое ли число}

    if (a[1] + a[2] + a[3] = a[4] + a[5] + a[6]) then

    begin

    {если счастливое, то выводим}

    write (happy,' ') ;

    ten:=ten+1;

    if ten>10 then

    {если уже напечатано 10 чисел, то переходим в новую строку}

    begin

    ten:=1;

    writeln () ;

    end;

    end;

    happy:=happy+7;

    end;

    end.
  2. 24 мая, 10:24
    0
    var

    b: integer;

    a: array [0 ... 5] of byte;

    begin

    for i: integer : = 100000 to 999999 do

    begin

    b : = i;

    for d: integer : = 0 to 5 do

    begin

    a[d] : = b mod 10;

    b : = b div 10;

    end;

    if (a[0] + a[1] + a[2] = a[3] + a[4] + a[5]) then

    writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести щестизначных "счастливых" чисел (сумма первых трех цифр равна сумме трех последних), кратных семи в 10 колонок. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачу с while ... Билет называют "счастливым", если в его номере сумма первых трех цифр равна сумме последних трех. Подсчитать число "счастливых" билетов и вывести их на экран (000000 до 999999).
Ответы (1)
Буду очень благодарна за помощь! 1) Вводятся натуральные числа, не превосходящие N. Вычислить произведение всех чисел, кратных 6. 2) Вывести все трехзначные числа, в которых сумма первых двух цифр равна сумме двух последних цифр.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)
Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет "счастливым", если сумма первых двух цифр его номера равна сумме последних двух цифр.
Ответы (1)
Сколько существует "счастливых" четырехзначных билетов? "Счастливым" считается билет, у которого сумма первых двух цифр равна сумме двух последних.
Ответы (1)