Задать вопрос
17 января, 14:24

Даны два натуральных числа. Выяснить в каком из них сумма цифр

больше. Написать программу в паскале абс, использую функцию.

+3
Ответы (1)
  1. 17 января, 15:00
    0
    Function summ (a : integer) : integer;

    var

    s : integer;

    begin

    s : = 0;

    while (a > 0) do

    begin

    s : = s + a mod 10;

    a : = a div 10;

    end;

    summ : = s;

    end;

    var

    a, b : integer;

    begin

    read (a, b) ;

    a : = summ (a) ;

    b : = summ (b) ;

    if a > b then write ('in 1') else if b > a then write ('in 2') else write ('eq') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два натуральных числа. Выяснить в каком из них сумма цифр больше. Написать программу в паскале абс, использую функцию. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
Пример 6. Составим функцию, которая вычисляет сумму цифр числа. Будем рассуждать так: сумма цифр числа n равна значению последней цифры плюс сумма цифр числа div (n, 10).
Ответы (1)
Автомат получает на вход два двузначных десятичных числа. По полученным числам строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма цифр первого числа и сумма цифр второго числа. 2.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)