Задать вопрос
12 июля, 06:02

Дан массив x (n, m) и число z. определить сколько раз среди элементов честных строк массива встречается число z с заданным значением

+4
Ответы (1)
  1. 12 июля, 08:55
    0
    Const

    n=5;

    m=6;

    var

    i, j, s, z:integer;

    a:array[1 ... n, 1 ... m]of integer;

    begin

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (10) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    readln (z) ;

    i:=2;

    while i<=n do

    begin

    for j:=1 to m do

    if a[i, j]=z then s:=s+1;

    i:=i+2;

    end;

    writeln ('Ответ: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив x (n, m) и число z. определить сколько раз среди элементов честных строк массива встречается число z с заданным значением ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)