Задать вопрос
29 августа, 12:03

Нужна помощь, буду очень благодарен.

Создайте файл f, компоненты которого являются действительными числами. Напишите программу вычисления суммы компонентов файла f и произведения ненулевых компонентов этого файла.

Язык программирования: Pascal

+2
Ответы (2)
  1. 29 августа, 14:53
    0
    Uses crt;

    var f:text;

    i, x, sm, n:integer;

    pr:longint;

    begin

    randomize;

    clrscr;

    pr:=1;

    assign (f,'f. txt') ; rewrite (f) ;

    writeln ('Введите число заполнений (например 6, в файле будет шесть натуральных чисел) ?') ; readln (n) ;

    for i:=1 to n do

    begin

    write (i,') ') ;

    readln (x) ;

    writeln (f, x) ;

    end;

    close (f) ;

    reset (f) ;

    while not Eof (f) do

    begin

    read (f, x) ;

    sm:=sm+x;

    if x 0 then pr:=pr*x;

    end;

    if n 0then

    begin

    writeln;

    writeln ('Сумма всех чисел = ', sm) ;

    writeln ('Произведение всех чисел = ', pr) ;

    end else writeln ('Файл пустой.') ;

    readkey;

    close (f) ; end.
  2. 29 августа, 15:00
    0
    Cvar

    f: Text;

    k: integer;

    s, p: longint;

    i: integer;

    begin

    Assign (f, 'output. dat') ;

    Rewrite (f) ;

    writeln ('Вводите данные, окончание число 7777') ;

    repeat

    read (k) ;

    if k7777 then writeln (f, k)

    until k=7777;

    Close (f) ;

    Reset (f) ;

    s : = 0;

    p : = 1;

    writeln;

    while not Eof (f) do

    begin

    readln (f, k) ;

    write (k:4) ;

    s : = s + k;

    if k 0 then p : = p * k

    end;

    Close (f) ;

    writeln;

    writeln ('Сумма = ', s, ', произведение = ', p)

    end.

    Вводите данные, окончание число 7777

    3

    6

    -4

    6

    2

    -3

    -4

    2

    6

    0

    5

    -1

    7777

    3 6 - 4 6 2 - 3 - 4 2 6 0 5 - 1

    Сумма = 18, произведение = 622080
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна помощь, буду очень благодарен. Создайте файл f, компоненты которого являются действительными числами. Напишите программу вычисления ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
Когда используется команда меню Файл - Сохранить Выберите один из 3 вариантов ответа: 1) Когда мы хотим сохранить файл и при этом оставить исходный вариант файла 2) Когда мы хотим сохранить файл и при этом он перезапишет исходный вариант файла 3)
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)