Задать вопрос
27 декабря, 23:44

Написать программу с исаользованием функции. Дано N целых чисел. Подсчитеть количество чисел, в записи которых нет цифры 8.

+3
Ответы (1)
  1. 28 декабря, 01:51
    0
    Var A:Array[1 ... 100] of Word; N, Max_S, i, I_max:Byte; Function Sum_of_figures (p:Word) : Byte; var d:Word; S, j:Byte; begin d:=10000; S:=0; For j:=1 to 5 do begin S:=S + (p div d) ; p:=p mod d; d:=d div 10; end; Sum_of_figures:=S; end; Begin Randomize; Write ('N = ') ; Readln (N) ; Writeln; Writeln ('Initial array:') ; For i:=1 to N do begin A[i]:=Random (65535) ; Write (A[i]:8) ; end; Writeln; Writeln; Writeln ('Sums of figures:') ; Max_S:=0; For i:=1 to N do begin Write (Sum_of_figures (A[i]) : 8) ; If Sum_of_figures (A[i]) >Max_S then begin Max_S:=Sum_of_figures (A[i]) ; I_max:=i; end; end; Writeln; Writeln; Writeln ('Maximal sum of figures (', Max_S,') has the element N', I_max,' equal to ', A[I_max]) ; Readln; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу с исаользованием функции. Дано N целых чисел. Подсчитеть количество чисел, в записи которых нет цифры 8. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите написать программу по программированию Напишите программу которая в последовательности целых чисел определяет количество чисел оканчивающихся на 5 или кратных 3.
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)