Задать вопрос
2 апреля, 21:52

В одном массиве произвольных чисел найдите количество нечетных элементов (Паскаль)

+2
Ответы (1)
  1. 3 апреля, 00:54
    0
    Const

    n=20;

    var

    a:array[1 ... n] of integer;

    i, s:integer;

    begin

    writeln ('Исходный массив') ;

    s:=0;

    Randomize;

    for i:=1 to n do begin

    a[i]:=Random (100) - 50;

    if a[i] mod 2 0 then s:=s+1;

    write (a[i]:5)

    end;

    writeln;

    writeln ('Количество нечетных элементов равно ', s)

    end.

    Тестовое решение:

    Исходный массив

    -10 - 26 - 5 36 - 48 41 - 10 5 46 - 1 - 5 1 19 - 11 - 10 31 9 - 31 - 4 - 40

    Количество нечетных элементов равно 11
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одном массиве произвольных чисел найдите количество нечетных элементов (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Поиск в массиве. Сформулировать случайный массив из 10 элементов, содержащий целые числа от 0 до 5. Вывести номера нечётных элементов. Если их в массиве не окажешься. Вывести надпись " нечётных элементов нет"
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
В одномерном массиве произвольных чисел найти количество нечётных элементов (паскаль)
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)