Задать вопрос
17 мая, 18:34

В одномерном массиве произвольных чисел найти количество нечётных элементов (паскаль)

+3
Ответы (1)
  1. 17 мая, 19:28
    0
    function f (a: array of integer) : byte;

    begin

    foreach i: integer in a do

    if (i mod 2 = 1) then

    result + = 1;

    end;

    begin

    var a: array of integer : = new integer[50];

    for var i : = 0 to 49 do

    begin

    a[i] : = random (1, 300000) ;

    write (a[i], ' ') ;

    end;

    writeln (#13, #13, f (a)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве произвольных чисел найти количество нечётных элементов (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
В одномерном массиве М, состоящем из 10 целых чисел, найти: а) количество нулевых элементов: б) сумму элементов, больших - 4: В) полу сумму элементов с четными индексами: г) произведение нечетных элементов
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Cоставить программу в паскале. В одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.
Ответы (1)