Задать вопрос
23 апреля, 01:06

Дан массиы, содержащий 50 элементов. Найти среднее арифмитическое элементов массива, состоящих на местах кратных 5

+2
Ответы (1)
  1. 23 апреля, 04:39
    0
    Var a:array[1 ... 50] of integerl;

    sr:real;

    kol, i:integer;

    begin

    for i:=1 to 50 do

    readln (a[i]) ;

    kol:=0;

    sr:=0;

    i:=5;

    while i<=50 do

    begin

    sr:=sr+a[i];

    kol:=kol+1;

    i:=i+5;

    end;

    writeln (sr/kol) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массиы, содержащий 50 элементов. Найти среднее арифмитическое элементов массива, состоящих на местах кратных 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)