Задать вопрос
4 марта, 09:11

Даны две дроби A/B и C/D (A, B, C, D-натуральные числа). Составить программу для умножения дроби на дробь. Результат должен быть несократимой дробью.

Желательно через процедуру.

+1
Ответы (1)
  1. 4 марта, 12:22
    0
    program test;

    var

    a, b, c, d:real;

    begin

    readln (a, b, c, d) ;

    if (a>0) and (b>0) and (c>0) and (d>0) then

    writeln ((a/b) * (c/d)) ;

    end.

    Вводим a, b, c, d с клавиатуры. Процедуру можешь сам включить сюда, там не сложно.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две дроби A/B и C/D (A, B, C, D-натуральные числа). Составить программу для умножения дроби на дробь. Результат должен быть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
Ребят, помогите, ничего вообще не понимаю ... ((Что вообще за модуль, содержащий процедуру ... нужно написать программу) если можно с объяснениями) Написать модуль, содержащий процедуру нахождения минимальной цифры натурального числа.
Ответы (1)
Составить процедуру определения среднего арифметического значения элементов одномерного массива А[m]. Используя процедуру, определить среднее арифметическое побочной диагонали квадратной матрицы B[m, m].
Ответы (1)