Задать вопрос
10 апреля, 16:41

Найти все симметричные натуральные числа из

промежутка от A до B (А и B вводятся с

клавиатуры)

+2
Ответы (1)
  1. 10 апреля, 19:43
    0
    Var

    i, a, b, n, n2, j: longint;

    s: string;

    flag: boolean;

    begin

    Write ('Введите через пробел границы диапазона: ') ;

    Readln (a, b) ;

    if b < a then begin n : = a; a : = b; b : = n end;

    if a < 11 then a : = 11;

    for i : = a to b do

    begin

    Str (i, s) ;

    n : = Length (s) ; n2 : = n div 2; flag : = true; j : = 1;

    repeat

    flag : = (s[j] = s[n - j + 1]) ;

    j : = j + 1

    until (not flag) or (j > n2) ;

    if flag then Write (i, ' ')

    end;

    end.

    Тестовое решение:

    Введите через пробел границы диапазона: 800 1500

    808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999 1001 1111 1221 1331 1441
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все симметричные натуральные числа из промежутка от A до B (А и B вводятся с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Найти симметричные натуральные числа из промежутка от А до В (А и В вводятся с клавы). паскаль
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)