Задать вопрос
30 июля, 20:26

Определите среднее арифметическое элементов массива.

+1
Ответы (1)
  1. 30 июля, 21:17
    0
    Uses crt;

    const n = 5;

    var a:array[1 ... n] of integer;

    sun, k, i:integer;

    begin

    for i:=1 to n do

    readln (a[i]) ;

    sum:=0; k:=0;

    for i:=1 to n do

    begin

    sum:=sum+a[i];

    k:=k+1;

    end;

    writeln (sum/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите среднее арифметическое элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан массив из 8 элементов. Определить а) сумму всех элементов массива; б) произведение всех элементов массива; в) среднее арифметическое всех элементов массива
Ответы (1)