Задать вопрос
5 мая, 16:21

Дан масcив из N целых чисел. Написать программу, определяющую, сколько в массиве чисел, равных максимальному элементу массива.

+3
Ответы (1)
  1. 5 мая, 18:11
    0
    Uses crt;

    const M = 100;

    var a: array [1 ... M] of integer;

    i, max, k, n: integer;

    begin clrscr;

    repeat

    writeln ('Введите количество элементов массива') ;

    readln (n) ;

    until (n 0) and (n>0) ;

    for i : = 1 to n do

    begin

    writeln ('Введите [', i, '] элемент массива') ;

    readln (a[i]) ;

    end;

    for i : = 1 to n do

    write (' ', a[i]) ;

    writeln;

    max : = a[1];

    for i : = 2 to n do

    if a[i] > max then max : = a[i];

    writeln (' max = ', max) ;

    for i : = 1 to n do

    if a[i] = max then k : = k + 1;

    writeln (' k = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан масcив из N целых чисел. Написать программу, определяющую, сколько в массиве чисел, равных максимальному элементу массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)