Задать вопрос
11 апреля, 09:30

С клавиатуры задано целое трехзначное число. Определите, есть ли среди цифр задуманного числа одинаковые.

кумир

+5
Ответы (1)
  1. 11 апреля, 12:33
    0
    Усложнённый вариант (всё работает исправно, при вводе больше или меньше 3 чисел выводится сообщение "Это не трёхзначное число!") : var

    i, a, d:integer;

    s:string;

    begin

    writeln ('Введите трёхзначное число ') ;

    read (s) ;

    d:=length (s) ;

    if d3 then

    write ('Это не трёхзначное число!') ;

    if d=3 then

    if (s[1]=s[2]) or (s[1]=s[3]) or (s[2]=s[3]) then

    write ('Да')

    else

    write ('Нет') ;

    end. Простой вариант (выводится ошибка если цифр больше или меньше трёх!) : var

    i, a, d:integer;

    s:string;

    begin

    writeln ('Введите трёхзначное число ') ;

    read (s) ;

    if (s[1]=s[2]) or (s[1]=s[3]) or (s[2]=s[3]) then

    write ('Да')

    else

    write ('Нет') ;

    endю
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры задано целое трехзначное число. Определите, есть ли среди цифр задуманного числа одинаковые. кумир ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. С клавиатуры вводится число от 100 до 9999. Если число трехзначное, то найти произведение его цифр. Если четырехзначное, то найти сумму этих цифр. 2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.
Ответы (1)