Задать вопрос
18 ноября, 19:34

Написать программу с использованием оператора цикла (постусловия).

Резервуар имеет форму сферы; его внутренний радиус равен R см Найдите объем (V) жидкости в зависимости от от уровня h воды от низшей точки его дна. Величина h изменяется от 0 до 2 с шагом 0,1. Объем V шарового сегмента (заполненого жидкостью) вычисляется по формуле πh² (R-h/3).

+1
Ответы (1)
  1. 18 ноября, 21:49
    0
    const

    pi=3.14;

    var

    h, V, R: real;

    begin

    writeln ('Введите радиус') ;

    Readln (R) ;

    h:=0;

    repeat

    V:=pi*sqr (h) * (R-h/3) ;

    writeln ('V (', h,') = ', V) ;

    h:=h+0.1;

    until h>2.1;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу с использованием оператора цикла (постусловия). Резервуар имеет форму сферы; его внутренний радиус равен R см Найдите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
1) Вывести Чётные числа с 18 до 62 с использованием оператора цикла "for" 2) Вывести нечётные числа в обратном порядке с 31 до 1 с использованием оператора цикла "for".
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Y=tgx при х изменяется от 0 до 10 Написать программу так чтобы она решала задачу с использованием оператора цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)