Задать вопрос
17 июня, 02:10

Дан массив из N целых чисел. Zero - quadruple - это произвольные четыре числа из этого массива, сумма которых равна нулю. Найдите сколько различных Zero - quadruple существует в этом массиве

+1
Ответы (1)
  1. 17 июня, 04:35
    0
    Var a:array [1 ... 100] of integer;

    n, i, zq, k, l, j: integer;

    begin

    readln (n) ;

    for i:=1 to n do a[i] : = random (500) - 249;

    for i : = 1 to n do

    for j : = i to n do

    for k : = j to n do

    for l : = k to n do

    if a[i] + a[j] + a[k] + a[l] = 0 then inc (zq) ;

    writeln (zq) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N целых чисел. Zero - quadruple - это произвольные четыре числа из этого массива, сумма которых равна нулю. Найдите сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив из N различных целых чисел Zero - это произвольная четыре числа из этого массива, сумма которых равна нулю. Найдите сколько различных zero существует на этой массиве.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)