Задать вопрос
4 декабря, 19:35

Дан массив, состоящий из n элементов, и числа a и b. Вычислить.

Y=П (от 1 до n) a (в степени xi) - b (в степени xi)

+2
Ответы (1)
  1. 4 декабря, 21:21
    0
    Program ABC;

    var

    X:array [1 ... 27] of integer;

    i, n, a, b:integer;

    y:real;

    Begin

    y:=1;

    write ('введите количество элементов массива n = ') ;

    readln (n) ;

    write ('введите число a = ') ;

    readln (a) ;

    write ('введите число b = ') ;

    readln (b) ; For i: = 1 to n do

    Begin

    X[i]: = - 10+random (25) ;

    write (X[i]:4) ;

    y:=y * (exp (a * (X[i])) - exp (b * (X[i]))) ;

    end;

    writeln;

    write ('Y = ', y) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив, состоящий из n элементов, и числа a и b. Вычислить. Y=П (от 1 до n) a (в степени xi) - b (в степени xi) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)