Задать вопрос
31 августа, 04:28

Написать программу, определяющую, принадлежит ли точка с координатами (x, y) кольцу с центром (x0, y0). R1 и r2 соответственно радиусы внутренней и внешней окружностей, образующих кольцо.

+1
Ответы (1)
  1. 31 августа, 07:27
    0
    Var x, y, r1, r2:real;

    begin

    write ('Введите x, y, внутренний радиус, внешний радиус: ') ;

    readln (x, y, r1, r2) ;

    if (x*x+y*y=r1*r1) then

    writeln ('Да, принадлежит')

    else writeln ('Нет, не принадлежит') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, определяющую, принадлежит ли точка с координатами (x, y) кольцу с центром (x0, y0). R1 и r2 соответственно радиусы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) PS: Pascal (не турбо) Всем буду
Ответы (1)
Даны длины радиусов двух окружностей. Составьте программу определяющую разность площадей этих окружностей
Ответы (1)