Задать вопрос
21 апреля, 06:52

Дан одномерный массив {Ai}, состоящий из n элементов. Вычислить среднее арифметическое значение этих элементов

+2
Ответы (1)
  1. 21 апреля, 09:28
    0
    Uses crt;

    Var m:array[1 ... 1000] of integer;

    I, sr, n:integer;

    Begin

    Clrscr;

    Writeln ('Введите размер массива') ;

    Readln (n) ;

    For i:=1 to n do

    Begin

    m[i]:=random (30) + 1;

    Write (m[i],' ') ;

    Sr:=sr+m[i];

    End;

    Writeln;

    Writeln (' Сред. Арф. = ', sr div n) ;

    Readkey;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив {Ai}, состоящий из n элементов. Вычислить среднее арифметическое значение этих элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)