Задать вопрос
19 июля, 18:43

Дано натуральное число. Определить каких цифр в данном числе больше четных или нечетных. Через Паскаль

+4
Ответы (1)
  1. 19 июля, 22:37
    -1
    Var n:longint;

    s:string;

    i, ch, neCh:integer;

    begin

    readln (n) ;

    s:=intToStr (n) ;

    i:=1;

    while (i < = length (s)) do

    begin

    if (strToInt (s[i]) mod 2 = 1) then neCh:=neCh+1

    else ch:=ch+1;

    i:=i+1;

    end;

    if (ch > neCh) then writeln ('Чётных чисел больше') ;

    if (ch < neCh) then writeln ('Нечётных чисел больше') ;

    if (ch = neCh) then writeln ('Чётных и нечётных чисел поровну') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Определить каких цифр в данном числе больше четных или нечетных. Через Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)