Задать вопрос
31 мая, 21:09

Разработать алгоритм и составить программу на выбранном языке программирования (Паскаль или Qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

+4
Ответы (1)
  1. 31 мая, 22:29
    0
    Var

    m, n, p: integer;

    begin

    Write ('Введите свой номер в группе: ') ;

    Readln (n) ;

    n : = n * 12;

    p : = 1;

    repeat

    m : = n mod 10;

    p : = p * m;

    n : = n div 10

    until n = 0;

    Writeln ('Результат ', p)

    end.

    Тестовое решение:

    Введите свой номер в группе: 13

    Результат 30
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать алгоритм и составить программу на выбранном языке программирования (Паскаль или Qbasic) для нахождения произведения цифр числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Нужно сделать блок-схему, алгоритм и написать программу QBasic Задача - Найти произведение однозначных положительных цифр. (это циклический алгоритм) цифры - 1,2,3 ... 9
Ответы (1)