Задать вопрос
15 января, 23:50

Дано натуральное число N. Определить, верно ли, что это число содержит ровно три одинаковые цифры.

Решите алгоритмом

+1
Ответы (1)
  1. 16 января, 03:49
    0
    Var

    a, b, c, x:integer;

    begin

    write ('Введите трехзначное число. X=') ;

    readln (x) ;

    a:=x div 100;

    b: = (x mod 100) div 10;

    c: = (x mod 10) div 1;

    if (a=b) and (b=c) then writeln ('Верно!')

    else writeln ('Не верно') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. Определить, верно ли, что это число содержит ровно три одинаковые цифры. Решите алгоритмом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Выберите правильный ответ Алгоритм, в котором действия выполняются в порядке их записи, то есть последовательно друг за другом, называют: Алгоритмом с ветвлением. Алгоритмом с повторением. Линейным алгоритмом.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Закончите предложение: "Алгоритмом называется ..." 2. Выберите верный вариант. Алгоритмом можно считать: 1) описание решения квадратного уравнения; 2) расписание уроков в школе; 3) технический паспорт автомобиля; 4) список класса в журнале 3.
Ответы (1)