Задать вопрос
13 февраля, 17:34

Составте программу, которая заполняет массив а [ 1 ... 10] случайными целыми числами в диапозоне от 0 до 10 и находит максималый эллемент массива среди эллементов с четными индексами

+2
Ответы (1)
  1. 13 февраля, 21:12
    0
    Var a: array [1 ... 10] of integer;

    i, max: integer;

    begin

    max: = 0;

    write ('Исходный массив: ') ;

    for i: = 1 to 10 do

    begin

    a[i]: = random (10) ;

    write (a[i], ' ') ;

    if (i mod 2 = 0) and (a[i] > max) then

    max: = a[i];

    end;

    writeln;

    writeln ('Максимальный элемент массива среди элементов с четными индексами: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу, которая заполняет массив а [ 1 ... 10] случайными целыми числами в диапозоне от 0 до 10 и находит максималый эллемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Составьте программу которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами
Ответы (1)