Задать вопрос
16 февраля, 08:33

Дан целочисленный массив, элементы которого могут принимать значения от 0 до 1000. Разработать алгоритм, который позволяет найти сумму двухзначных элементов массива, сумма цифр которых меньше 10. Количество элементов массива и их задаются в программе.

+2
Ответы (2)
  1. 16 февраля, 11:37
    0
    Uses crt;

    var i, n, summa, a:integer;

    m:array [1 ... 1000] of integer;

    begin

    clrscr;

    writeln ('Введите размер массива') ;

    readln (n) ;

    for i:=1 to n do

    m[i]:=i;

    if n<99 then a:=n else a:=99;

    for i:=10 to a do

    begin

    if (i div 10) + (i mod 10) < 10 then

    begin

    summa:=summa+i;

    end;

    end;

    writeln (summa) ;

    readkey;

    end.
  2. 16 февраля, 11:41
    0
    Const n=30;

    var

    x, i, s:integer;

    a:array[1 ... n]of integer;

    begin

    writeln ('Массив:') ;

    for i:=1 to n do

    begin

    x:=random (1000) ;

    a[i]:=x;

    write (x,' ') ;

    if (x>10) and (x<100) and ((x div 10) + (x mod 10) <10) then s:=s+a[i];

    end;

    writeln;

    writeln ('Ответ: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив, элементы которого могут принимать значения от 0 до 1000. Разработать алгоритм, который позволяет найти сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Дан целочисленный массив из 35 элементов элементы массива могут принимать целые значения от 0 до 1000. составьте программу позволяющию найти и вывести сумму элементов в массив из 35 элементов массива, кратных тринадцати
Ответы (1)
Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не делятся на 3
Ответы (1)