Задать вопрос
15 июня, 13:53

Решите задачу в паскале программа джини

найдите полупроизведение всех положительных элементов массива

+3
Ответы (1)
  1. 15 июня, 15:12
    0
    Может быть это? pascal:

    var a: array [1 ... 20] of integer;

    i, k: integer;

    s: real;

    begin

    / / заполняем массив c клавиатуры

    for i:=1 to 20 do

    readln (ar) ;

    //считаем среднеариф-е

    s : = 0;

    k : = 0;

    for i:=1 to 20 do

    if a >=0 then begin

    s : = s + a;

    k : = k + 1;

    end;

    writeln ('среднее: ', s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачу в паскале программа джини найдите полупроизведение всех положительных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)