Задать вопрос
29 октября, 13:28

Pascal. Задана последовательность символов, за которой следует точка (в саму последовательность точка не входит). Напечатать текст, удалив из него все цифры.

+4
Ответы (1)
  1. 29 октября, 16:15
    0
    Var i, n : longint; c : array [1 ... 100] of char;

    begin

    readln (n) ;

    for i:=1 to n do readln (c[i]) ;

    for i:=1 to n do

    if (c[i]'1') and

    (c[i]'2') and

    (c[i]'3') and

    (c[i]'4') and

    (c[i]'5') and

    (c[i]'6') and

    (c[i]'7') and

    (c[i]'8') and

    (c[i]'9') and

    (c[i]'0')

    then writeln (c[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Задана последовательность символов, за которой следует точка (в саму последовательность точка не входит). Напечатать текст, удалив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от знака решотка дважды. Вывести на экран, полученную новую строку.
Ответы (1)