Задать вопрос
20 июля, 02:32

Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать цикл с предусловием while do. Информатика. 8 класс. Паскаль ABC.

+1
Ответы (1)
  1. 20 июля, 05:11
    0
    Var n:integer; var b:array[0 ... 9] of boolean; var f:boolean; begin f : = false; readln (n) ; while n > 0 do begin if b[n mod 10] then begin f : = true; break; end else b[n mod 10] : = true; n : = n div 10; end; if f then writeln ('da') else writeln ('net') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)