Задать вопрос
14 июня, 16:54

Дано натуральное число n определите количество цифр в цифровой записи его числа, которые имеют наибольшее значение пример N=1808, количество чифр с наибольшим значением равно 2 (две циры 8)

+3
Ответы (1)
  1. 14 июня, 20:47
    0
    Var n, amount, max_digit, copy_of_n: integer;

    begin

    read (n) ;

    copy_of_n : = n;

    amount : = 0;

    max_digit : = copy_of_n mod 10;

    while copy_of_n 0 do

    begin {Находим наибольшую цифру в числе}

    if max_digit < copy_of_n mod 10

    then

    max_digit : = copy_of_n mod 10;

    copy_of_n : = copy_of_n div 10;

    end;

    copy_of_n : = n;

    while copy_of_n 0 do {Считаем количество таких цифр}

    begin

    if copy_of_n mod 10 = max_digit

    then

    amount : = amount + 1;

    copy_of_n : = copy_of_n div 10;

    end;

    writeln (amount) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n определите количество цифр в цифровой записи его числа, которые имеют наибольшее значение пример N=1808, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)