Задать вопрос
10 сентября, 23:53

Написать программу вычисления значения функции

x^2 x>5

y = 17x-1 npи - 7<х<=5

25 при x<=-7

+4
Ответы (1)
  1. 11 сентября, 00:26
    0
    Var

    x, y:real;

    begin

    Write ('Введите значение аргумента x: ') ;

    Readln (x) ;

    if x<=-7 then y:=25

    else

    if x<=5 then y:=17*x-1

    else y:=sqr (x) ;

    Writeln ('Значение функции равно ', y:0:4)

    end.

    Тестовое решение:

    Введите значение аргумента x: 3.78

    Значение функции равно 63.2600
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу вычисления значения функции x^2 x>5 y = 17x-1 npи - 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)