Задать вопрос
6 апреля, 02:12

Язык Pascal ABC. Напишите программу:

Дан двухмерный массив A[1 ... m, 1 ... n]. Написать программу построения одномерного массива B[1 ... m], элементы которого соответственно равны суммам элементов строк.

+5
Ответы (1)
  1. 6 апреля, 03:01
    0
    Const

    m=100;

    n=100;

    var

    a:array[1 ... m, 1 ... n]of integer;

    b:array[1 ... m]of integer;

    i, j:integer;

    begin

    for i:=1 to m do

    for j:=1 to n do

    a[i, j]:=random (200) - 100;

    for i:=1 to m do

    b[i]:=0;

    for i:=1 to m do

    for j:=1 to n do

    b[i]:=b[i]+a[i, j];

    for i:=1 to m do

    write (b[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык Pascal ABC. Напишите программу: Дан двухмерный массив A[1 ... m, 1 ... n]. Написать программу построения одномерного массива B[1 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)