Задать вопрос
28 января, 01:32

Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в сле дующем порядке: x1y1 х2, у2, х3, у3, и т. д. Определить минимальный радиус круга с центром в начале координат, который содержит все точки"

+1
Ответы (1)
  1. 28 января, 03:05
    0
    const

    n = 5;

    var

    arr: array [1 ... 2*n] of integer : = (0,1, - 2,1, - 1,-1, 1,2, - 3,0) ;

    i: byte : = 1;

    maxr: real;

    begin

    repeat

    maxr : = max (sqrt (sqr (arr[i]) + sqr (arr[i + 1])), maxr) ;

    i + = 2;

    until (i > 2 * n - 1) ;

    writeln (maxr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в basic." В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в следующем порядке: x1, y1, х2, у2, х3, у3, и т. д.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
написать программу на языке Паскаля. Заданы координаты двух точек. Определите, расположены ли они на одной окружности с центром в начале координат. Результат присвоить символьной переменной.
Ответы (1)