Задать вопрос
13 марта, 22:32

Подсчитать сумму вводимых чисел до первого отрицательного числа (использовать цикл с постусловием).

+4
Ответы (1)
  1. 13 марта, 23:36
    0
    program summa;

    var a: = 0;

    var b: = 0;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if a>0 then

    repeat {повторяй}

    a: = a+b;

    writeln ('Введите еще число') ;

    readln (b) ;

    until (b<0) ; {до тех пор, пока условие не будет истинным}

    writeln ('Было обнаружено отрицательное число') ;

    if a>0 then

    writeln ('Полученная сумма: ', a)

    else writeln ('Отрицательное число было первым') ;

    readln;

    end.

    Программа на выходе сообщает:

    Введите число

    3

    Введите еще число

    45

    Введите еще число

    9

    Введите еще число

    -8

    Было обнаружено отрицательное число

    Полученная сумма: 57
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать сумму вводимых чисел до первого отрицательного числа (использовать цикл с постусловием). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)