Задать вопрос
1 мая, 05:24

Дано натуральное число. Определить количество его нечетных делителей.

написать программу паскаль)

+1
Ответы (1)
  1. 1 мая, 07:34
    0
    Var n, i, k:Integer;

    Begin

    Read (n) ;

    for i:=1 to n do

    if (n mod i = 0) and (i mod 2 0) then k:=k+1;

    Writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Определить количество его нечетных делителей. написать программу паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)