Задать вопрос
15 ноября, 09:57

Pascal.

Даны четыре натуральных числа. Найти наименьшее общее кратное (НОК) для этих четырех чисел. Поиск НОК двух чисел оформить функцией.

+4
Ответы (1)
  1. 15 ноября, 13:04
    0
    Var a, b, c, d, x, y: longint;

    function NOD (a, b:integer) : integer;

    begin

    while (a0) and (b0) do

    if a>=b then a: = a mod b

    else b: = b mod a;

    NOD:=a+b;

    end;

    function NOK (a, b:integer) : integer;

    begin

    NOK:=a*b div NOD (a, b)

    end;

    Begin

    Read (a, b, c, d) ;

    x:=NOK (a, b) ;

    y:=NOK (c, d) ;

    Writeln (NOK (x, y)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Даны четыре натуральных числа. Найти наименьшее общее кратное (НОК) для этих четырех чисел. Поиск НОК двух чисел оформить функцией. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Какого типа информации в поисковых системах не существует: а) поиск по любому из слов в) поиск по всем словам с) поиск по синонимам д) поиск точно по фразе
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)