Задать вопрос
23 июля, 08:40

Паскаль. Дана строка N символов. Вывести все слова с удвоенными буквами

+3
Ответы (1)
  1. 23 июля, 10:37
    0
    Var

    n, i:integer;

    s, t:string;

    f:boolean;

    begin

    readln (s) ;

    n:=length (s) ;

    f:=false;

    for i:=2 to n do

    begin

    t:=t+s[i];

    if s[i]=s[i-1] then f:=true;

    if (s[i]=' ') or (i=n) then

    begin

    if f then writeln (t) ;

    t:='';

    f:=false;

    end

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Дана строка N символов. Вывести все слова с удвоенными буквами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)