Задать вопрос
19 июля, 02:07

Дано двухзначное (трехзначное) число.

Напишите программу определения

- входит ли в него цифра 5

-входят ли в него цифры 4 и 7

+1
Ответы (1)
  1. 19 июля, 03:38
    0
    Var a, b, c, d:integer;

    begin

    readln (a) ;

    b:=a div 100;

    c:=a mod 100 div 10;

    f:=a mod 100 mod 10;

    if (b=5) or (c=5) or (f=5) then write ('входит')

    else write ('невходит') ;

    if (b=7) or (b=4) or (c=7) or (c=4) or (f=7) or (f=4) then write ('входит')

    else write ('невходит') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано двухзначное (трехзначное) число. Напишите программу определения - входит ли в него цифра 5 -входят ли в него цифры 4 и 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Нарисуй в окне цепочку П из пяти цифр так, чтобы все пять утверждений были истенными: В цепочке П цифра 3 идет раньше цифры 9. В цепочке П цифра 2 идет позже цифры 6. В цепочке П цифра 6 идет раньше цифры 9. В цепочке П цифра 6 идет позже цифры 5.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Конструктор алгоритмов. Дано двузначное (трехзначное) число. Написать программу определения: входит ли в него цифра 5?
Ответы (1)
Есть числовой ряд: 101112 ... 979899, в котором подряд выписаны все двухзначные числа. Определить двухзначное число из этого ряда, образованное парой цифр, в которую входит k-ая цифра. k вводится и лежит в диапазоне от 1 до 180.
Ответы (1)